PHP 5.3 Extensions For Windows

自己动手丰衣足食。继续编译中,有好的扩展可以推荐来~~

这里的dll都是仅适用于php 5.3 vc9版本。

注:下边扩展只适用于PHP 5.3,至于其他扩展,估计到处都有了,不用重复造轮子。

php_imagick.dll

php_ming.dll

php_apc.dll

Updated 2009-09-09:Add php_ming.dll for php5.3.0

Updated 2009-10-05:    php_apc.dll 已经添加,应bya之求。

–EOF–

9 thoughts on “PHP 5.3 Extensions For Windows”

  1. 兄弟,我装了PHP5.3 VC6,里面没有php_mcrypt.dll和libmcrypt.dll, 但我要启动php_mcrypt.dll,我就把PHP5.2中的php_mcrypt.dll和libmcrypt.dll拿来用,启动Apache后在日志中发现有这样错误:
    PHP Warning: PHP Startup: mcrypt: Unable to initialize module\nModule compiled with module API=20060613\nPHP compiled with module API=20090626\nThese options need to match\n in Unknown on line 0

    估计是不兼容问题,但我在网上找不到相关下载,也不知道如何编译,兄弟能不能帮忙编译个?

  2. 再请教个问题,PHP官方说在windows+apache环境下装PHP 5.3要选择VC6版本,网上搜到的全是相同的内容,而我当初却装了VC9Visual C++ 2008 Redistributable

  3. (不小心提交了,晕)
    而我当初却装了apache和PHP5.3 VC9,但已安装Visual C++ 2008 Redistributable,结果完全正常,这说明应该没问题吧?

  4. @luckgo
    PHP Warning: PHP Startup: mcrypt: Unable to initialize module\nModule compiled with module API=20060613\nPHP compiled with module API=20090626\nThese options need to match\n in Unknown on line 0

    这个错误是版本不一致导致的。比如,mcrypt的编译环境是VC9,它就不能运行在VC6版本的PHP中。否则你就报你这个错。

  5. 楼主,能否把你编译php_ming.dll的过程写个说明啊。我下载了你的php_ming.dll在php的VC9 x86 Non Thread Safe 版本下,加载这个dll不成功。谢谢。

Leave a Reply

Your email address will not be published. Required fields are marked *